wiki:unity-greeter

Unity-Greeter y el selector de idioma

Una de las opciones perdidas de gdm a lightdm es la seleccion de idioma de la sesion. Tal y como viene de ubuntu, para cambiar de idioma hay que entrar en la sesion, ir a Soporte de Idiomas y ordenar la lista de idiomas. Para que se pueda seleccionar antes de abrir la sesion se ha parcheado el paquete unity-greeter para añadir un menu desplegable de seleccion de idioma.

A dia de hoy, el paquete source://unity-greeter ya tiene los parches aplicados. En cualquier caso, el parche del original a este es el siguiente source://unity-greeter/trunk/doc/09_doc_adicional/llx-patch

El parche es el primero de los pasos, el segundo es el paquete source://liblightdm-gobject-1-dev-mod , que añade una modificacion a la api de vala para soportar el cambio de idioma. Este paquete ha de estar como dependencia de construccion de unity-greeter. Tal y como esta el paquete ahora mismo, solo ha de estar en el ppa o en la propia maquina en la que se construya, sustituye (via cp) en el postinst el fichero de la api de vala de esta libreria, lo cual no es precisamente respetar la debian policy, es por ello por lo que solo esta en launchpad simplemente para ayudar a la construccion (es decir, no esta exportado en el pool de lliurex)
El problema de mantener este paquete es que si hacemos una diversion, hay que estar pendiente del original y actualizar el fichero con la nueva api que pueda estar exportando el paquete original.

Independientemente de que algun dia se termine haciendo una diversion o no, es recomendable, antes de una nueva construccion de unity-greeter, actualizar el fichero .vapi de este paquete con el de liblightdm-gobject-1-dev y añadirle la linea que exporta set_language.

Last modified 3 years ago Last modified on Feb 27, 2015, 12:13:44 PM