source: adobe-flashplugin/trunk/fuentes/debian/adobe-flashplugin.postinst @ 2797

Last change on this file since 2797 was 2797, checked in by mabarracus, 4 years ago

Update flash

File size: 2.7 KB
Line 
1#!/bin/sh
2# postinst script for adobe-flashplugin
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#               * <postinst> `configure' <most-recently-configured-version>
10#               * <old-postinst> `abort-upgrade' <new version>
11#               * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#                 <new-version>
13#               * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
14#                 <failed-install-package> <version> `removing'
15#                 <conflicting-package> <version>
16# for details, see http://www.debian.org/doc/debian-policy/ or
17# the debian-policy package
18#
19
20case "$1" in
21        configure)
22       
23                update-alternatives --install "/usr/lib/mozilla/plugins/flashplugin-alternative.so" "mozilla-flashplugin" /usr/lib/adobe-flashplugin/libflashplayer.so 50
24                # LliureX Hack to solve the pluginreg.dat corruption
25                for f in $(ps aux |grep "/usr/lib/firefox/firefox" | grep -v "grep" | head -1 |cut -d " " -f1); do 
26                        echo " * Found some firefox running .... updating pluginreg.dat"
27                        for d in $(find /home/${f}/.mozilla/ -name "pluginreg.dat"); do 
28                                echo " * Found ${d}"
29                                sed -i "s%11\.2\.202\.310%11\.2\.202\.643%g" ${d} || true 
30                                sed -i "s%11\.2\.202\.425%11\.2\.202\.643%g" ${d} || true 
31                                sed -i "s%11\.2\.202\.440%11\.2\.202\.643%g" ${d} || true 
32                                sed -i "s%11\.2\.202\.451%11\.2\.202\.643%g" ${d} || true
33                                sed -i "s%11\.2\.202\.460%11\.2\.202\.643%g" ${d} || true
34                                sed -i "s%11\.2\.202\.468%11\.2\.202\.643%g" ${d} || true
35                                sed -i "s%11\.2\.202\.481%11\.2\.202\.643%g" ${d} || true
36                                sed -i "s%11\.2\.202\.491%11\.2\.202\.643%g" ${d} || true
37                                sed -i "s%11\.2\.202\.508%11\.2\.202\.643%g" ${d} || true
38                                sed -i "s%11\.2\.202\.521%11\.2\.202\.643%g" ${d} || true
39                                sed -i "s%11\.2\.202\.540%11\.2\.202\.643%g" ${d} || true
40                                sed -i "s%11\.2\.202\.548%11\.2\.202\.643%g" ${d} || true
41                                sed -i "s%11\.2\.202\.554%11\.2\.202\.643%g" ${d} || true
42                                sed -i "s%11\.2\.202\.559%11\.2\.202\.643%g" ${d} || true
43                                sed -i "s%11\.2\.202\.569%11\.2\.202\.643%g" ${d} || true
44                                sed -i "s%11\.2\.202\.577%11\.2\.202\.643%g" ${d} || true
45                                sed -i "s%11\.2\.202\.616%11\.2\.202\.643%g" ${d} || true
46                                sed -i "s%11\.2\.202\.621%11\.2\.202\.643%g" ${d} || true
47                                sed -i "s%11\.2\.202\.626%11\.2\.202\.643%g" ${d} || true
48                                sed -i "s%11\.2\.202\.635%11\.2\.202\.643%g" ${d} || true
49                                sed -i "s%11\.2\.202\.637%11\.2\.202\.643%g" ${d} || true
50                        done
51                done
52        ;;
53
54        abort-upgrade|abort-remove|abort-deconfigure)
55                echo "postinst called with argument \`$1'" >&2
56                exit 1
57        ;;
58
59        *)
60                echo "postinst called with unknown argument \`$1'" >&2
61                exit 1
62        ;;
63esac
64
65# dh_installdeb will replace this with shell code automatically
66# generated by other debhelper scripts.
67
68#DEBHELPER#
69
70exit 0
71
72# vim: ts=2 sw=2
Note: See TracBrowser for help on using the repository browser.