source: adobe-flashplugin/trunk/fuentes/debian/adobe-flashplugin.prerm @ 8

Last change on this file since 8 was 8, checked in by mabarracus, 4 years ago

ported trusty code from repo to xenial repo

File size: 1.3 KB
Line 
1#!/bin/sh
2# prerm script for adobe-flashplugin
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#               * <prerm> `remove'
10#               * <old-prerm> `upgrade' <new-version>
11#               * <new-prerm> `failed-upgrade' <old-version>
12#               * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
13#               * <deconfigured's-prerm> `deconfigure' `in-favour'
14#                 <package-being-installed> <version> `removing'
15#                 <conflicting-package> <version>
16# for details, see http://www.debian.org/doc/debian-policy/ or
17# the debian-policy package
18
19OLD_VARIANTS="iceape iceweasel mozilla firefox xulrunner midbrowser xulrunner-addons"
20
21case "$1" in
22        remove)
23                update-alternatives --remove "mozilla-flashplugin" /usr/lib/adobe-flashplugin/libflashplayer.so;
24                ;;
25        upgrade|deconfigure)
26                update-alternatives --remove "mozilla-flashplugin" /usr/lib/adobe-flashplugin/libflashplayer.so;
27                ;;
28        failed-upgrade)
29                # Clean up legacy symlinks on failed-upgrade until Ubuntu 10.04 is EOL
30                for p in $OLD_VARIANTS; do
31                        update-alternatives --remove "$p-flashplugin" /usr/lib/adobe-flashplugin/libflashplayer.so || true;
32                done
33                exit 0;
34                ;;
35        *)
36                echo "prerm called with unknown argument \`$1'" >&2
37                exit 1
38        ;;
39esac
40
41# dh_installdeb will replace this with shell code automatically
42# generated by other debhelper scripts.
43
44#DEBHELPER#
45
46exit 0
47
48# vim: ts=2 sw=2
Note: See TracBrowser for help on using the repository browser.