source: lightdm-running/trunk/fuentes/debian/lightdm-classroom.prerm @ 325

Last change on this file since 325 was 325, checked in by hectorgh, 5 years ago

adding project files

File size: 1.1 KB
Line 
1#!/bin/sh
2# prerm script for lliurex-gva
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <prerm> `remove'
10#        * <old-prerm> `upgrade' <new-version>
11#        * <new-prerm> `failed-upgrade' <old-version>
12#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
13#        * <deconfigured's-prerm> `deconfigure' `in-favour'
14#          <package-being-installed> <version> `removing'
15#          <conflicting-package> <version>
16# for details, see http://www.debian.org/doc/debian-policy/ or
17# the debian-policy package
18
19PACKAGE_NAME="lightdm-classroom"
20case "$1" in
21    remove|upgrade|deconfigure)
22
23        ORIGINAL_FILE="/etc/pam.d/lightdm"
24        if [ -L "$ORIGINAL_FILE" ] ; then
25                rm -rf "$ORIGINAL_FILE"
26                dpkg-divert --package $PACKAGE_NAME --rename --remove   $ORIGINAL_FILE
27        fi
28
29    ;;
30
31    failed-upgrade)
32    ;;
33
34    *)
35        echo "prerm called with unknown argument \`$1'" >&2
36        exit 1
37    ;;
38esac
39
40# dh_installdeb will replace this with shell code automatically
41# generated by other debhelper scripts.
42
43#DEBHELPER#
44
45exit 0
Note: See TracBrowser for help on using the repository browser.