source: lliurex-meta/trunk/fuentes/seeds/platform.xenial/d-i-requirements @ 439

Last change on this file since 439 was 439, checked in by kbut, 5 years ago

wip

File size: 1000 bytes
Line 
1These packages may be installed dynamically by d-i based on installation
2parameters. They should generally be made available on CDs.
3
4== Package management ==
5
6 * tasksel           # used by installer to install desktop etc.
7 * aptitude          # better text-mode package manager
8
9== Filesystems ==
10
11 * xfsprogs
12 * jfsutils
13 * hfsplus [powerpc]  # ColinWatson
14 * reiserfsprogs
15 * btrfs-tools
16 * lvm2
17 * mdadm
18 * dmsetup
19 * dmraid
20 * cryptsetup
21 * ecryptfs-utils
22
23== For language support in the installer ==
24
25 * console-terminus
26 * unifont
27
28== Hardware & Network Access ==
29
30 * mouseemu     # needed on Macs with single-button mice
31
32== Installer ==
33
34 * grub # needed for dmraid et al
35 * grub-efi [amd64]
36 * grub-efi-amd64-signed [amd64]
37 * shim-signed [amd64]
38 * mkvmlinuz [powerpc] # for nobootloader
39 * lupin-support [amd64 i386] # installer-for-windows
40 * uboot-mkimage [armel armhf] # needed on dove and omap for uboot
41 * uboot-envtools [armel armhf] # needed on omap for uboot
42 * installation-report
Note: See TracBrowser for help on using the repository browser.