source: lliurex-meta/trunk/fuentes/seeds/platform.xenial/required @ 439

Last change on this file since 439 was 439, checked in by kbut, 5 years ago

wip

File size: 1.3 KB
Line 
1This seed describes the packages at Priority: required. These packages are installed by the first pass of debootstrap, which extracts them (dpkg -x, without running maintainer scripts) in order to construct a basic environment into which it can chroot and install them properly.
2
3A system containing only required packages is not a supported Ubuntu system; you need to install at least the packages from minimal as well.
4
5We avoid following Recommends for this seed because it is processed by debootstrap, not apt, and debootstrap only does the minimum necessary.
6
7 * Feature: no-follow-recommends
8
9= UNIX =
10
11== Essential ==
12
13These are packages which have "Essential: yes" in their control file.
14
15 * base-files
16 * base-passwd    # ColinWatson
17 * bash
18 * bsdutils       # LaMontJones
19 * coreutils
20 * debianutils
21 * diffutils
22 * dpkg
23 * e2fsprogs
24 * findutils
25 * grep
26 * gzip
27 * hostname
28 * libc-bin
29 * login
30 * mount          # LaMontJones
31 * ncurses-base
32 * ncurses-bin
33 * perl-base
34 * sed
35 * tar            # LaMontJones
36 * util-linux     # LaMontJones
37
38Our init system:
39
40 * init
41
42In some sense, debconf isn't truly required, but it makes our life a lot easier to have it installed in the first pass.
43
44 * debconf
45
46Other packages necessary to get started:
47
48 * dash               # Much faster default shell
49 * locales
50 * makedev
51 * mawk
52 * passwd
53 * procps
54 * tzdata
Note: See TracBrowser for help on using the repository browser.