source: lliurex-statistics-blacklist/trunk/fuentes/debian/lliurex-statistics-blacklist.postinst @ 6817

Last change on this file since 6817 was 6817, checked in by mabarracus, 19 months ago

Update list
Provides blacklist for lliurex-analytics-server

File size: 1.2 KB
Line 
1#!/bin/sh
2# postinst script for lliurex-statistics-blacklist
3#
4# see: dh_installdeb(1)
5
6set -e
7
8. /usr/share/debconf/confmodule
9
10# summary of how this script can be called:
11#        * <postinst> `configure' <most-recently-configured-version>
12#        * <old-postinst> `abort-upgrade' <new version>
13#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
14#          <new-version>
15#        * <postinst> `abort-remove'
16#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
17#          <failed-install-package> <version> `removing'
18#          <conflicting-package> <version>
19# for details, see http://www.debian.org/doc/debian-policy/ or
20# the debian-policy package
21
22
23case "$1" in
24    configure)
25        if [ -d /usr/lib/analytics-server/analytics ];then
26                cp /etc/lliurex-analytics/blacklist.txt /usr/lib/analytics-server/analytics/ || true
27        fi
28    ;;
29   
30    abort-upgrade|abort-remove|abort-deconfigure)
31    ;;
32
33    *)
34        echo "postinst called with unknown argument \`$1'" >&2
35        exit 1
36    ;;
37esac
38
39# dh_installdeb will replace this with shell code automatically
40# generated by other debhelper scripts.
41
42#DEBHELPER#
43
44exit 0
Note: See TracBrowser for help on using the repository browser.