source: moodle/trunk/fuentes/admin/tool/installaddon/lang/en/tool_installaddon.php @ 136

Last change on this file since 136 was 136, checked in by mabarracus, 4 years ago

Ported code to xenial

File size: 9.5 KB
Line 
1<?php
2
3// This file is part of Moodle - http://moodle.org/
4//
5// Moodle is free software: you can redistribute it and/or modify
6// it under the terms of the GNU General Public License as published by
7// the Free Software Foundation, either version 3 of the License, or
8// (at your option) any later version.
9//
10// Moodle is distributed in the hope that it will be useful,
11// but WITHOUT ANY WARRANTY; without even the implied warranty of
12// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
13// GNU General Public License for more details.
14//
15// You should have received a copy of the GNU General Public License
16// along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
17
18/**
19 * Strings for the tool_installaddon component.
20 *
21 * @package     tool_installaddon
22 * @category    string
23 * @copyright   2013 David Mudrak <david@moodle.com>
24 * @license     http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
25 */
26
27defined('MOODLE_INTERNAL') || die();
28
29$string['acknowledgement'] = 'Acknowledgement';
30$string['acknowledgementmust'] = 'You must acknowledge this';
31$string['acknowledgementtext'] = 'I understand that it is my responsibility to have full backups of this site prior to installing additional plugins. I accept and understand that plugins (especially but not only those originating in unofficial sources) may contain security holes, can make the site unavailable, or cause private data leaks or loss.';
32$string['featuredisabled'] = 'The plugin installer is disabled on this site.';
33$string['installaddon'] = 'Install plugin!';
34$string['installaddons'] = 'Install plugins';
35$string['installexception'] = 'Oops... An error occurred while trying to install the plugin. Turn debugging mode on to see details of the error.';
36$string['installfromrepo'] = 'Install plugins from the Moodle plugins directory';
37$string['installfromrepo_help'] = 'You will be redirected to the Moodle plugins directory to search for and install a plugin. Note that your site full name, URL and Moodle version will be sent as well, to make the installation process easier for you.';
38$string['installfromzip'] = 'Install plugin from ZIP file';
39$string['installfromzip_help'] = 'An alternative to installing a plugin directly from the Moodle plugins directory is to upload a ZIP package of the plugin. The ZIP package should have the same structure as a package downloaded from the Moodle plugins directory.';
40$string['installfromzipfile'] = 'ZIP package';
41$string['installfromzipfile_help'] = 'The plugin ZIP package must contain just one directory, named to match the plugin. The ZIP will be extracted into an appropriate location for the plugin type. If the package has been downloaded from the Moodle plugins directory then it will have this structure.';
42$string['installfromziprootdir'] = 'Rename the root directory';
43$string['installfromziprootdir_help'] = 'Some ZIP packages, such as those generated by Github, may contain an incorrect root directory name. If so, the correct name may be entered here.';
44$string['installfromzipsubmit'] = 'Install plugin from the ZIP file';
45$string['installfromziptype'] = 'Plugin type';
46$string['installfromziptype_help'] = 'Choose the correct type of plugin you are about to install. Warning: The installation procedure can fail badly if an incorrect plugin type is specified.';
47$string['permcheck'] = 'Make sure the plugin type root location is writable by the web server process.';
48$string['permcheckerror'] = 'Error while checking for write permission';
49$string['permcheckprogress'] = 'Checking for write permission ...';
50$string['permcheckresultno'] = 'Plugin type location <em>{$a->path}</em> is not writable';
51$string['permcheckresultyes'] = 'Plugin type location <em>{$a->path}</em> is writable';
52$string['pluginname'] = 'Plugin installer';
53$string['remoterequestalreadyinstalled'] = 'There is a request to install plugin {$a->name} ({$a->component}) version {$a->version} from the Moodle plugins directory on this site. However, this plugin is <strong>already installed</strong> on the site.';
54$string['remoterequestconfirm'] = 'There is a request to install plugin <strong>{$a->name}</strong> ({$a->component}) version {$a->version} from the Moodle plugins directory on this site. If you continue, the plugin ZIP package will be downloaded for validation. Nothing will be installed yet.';
55$string['remoterequestinvalid'] = 'There is a request to install a plugin from the Moodle plugins directory on this site. Unfortunately the request is not valid and so the plugin cannot be installed.';
56$string['remoterequestpermcheck'] = 'There is a request to install plugin {$a->name} ({$a->component}) version {$a->version} from the Moodle plugins directory on this site. However, the location <strong>{$a->typepath}</strong> is <strong>not writable</strong>. You need to give write access for the web server user to the location, then press the continue button to repeat the check.';
57$string['remoterequestpluginfoexception'] = 'Oops... An error occurred while trying to obtain information about the plugin {$a->name} ({$a->component}) version {$a->version}. The plugin cannot be installed. Turn debugging mode on to see details of the error.';
58$string['validation'] = 'Plugin package validation';
59$string['validationmsg_componentmatch'] = 'Full component name';
60$string['validationmsg_componentmismatchname'] = 'Plugin name mismatch';
61$string['validationmsg_componentmismatchname_help'] = 'Some ZIP packages, such as those generated by Github, may contain an incorrect root directory name. You need to fix the name of the root directory to match the declared plugin name.';
62$string['validationmsg_componentmismatchname_info'] = 'The plugin declares its name is \'{$a}\' but that does not match the name of the root directory.';
63$string['validationmsg_componentmismatchtype'] = 'Plugin type mismatch';
64$string['validationmsg_componentmismatchtype_info'] = 'You have selected the type \'{$a->expected}\' but the plugin declares its type is \'{$a->found}\'.';
65$string['validationmsg_filenotexists'] = 'Extracted file not found';
66$string['validationmsg_filesnumber'] = 'Not enough files found in the package';
67$string['validationmsg_filestatus'] = 'Unable to extract all files';
68$string['validationmsg_filestatus_info'] = 'Attempting to extract file {$a->file} resulted in error \'{$a->status}\'.';
69$string['validationmsg_foundlangfile'] = 'Found language file';
70$string['validationmsg_maturity'] = 'Declared maturity level';
71$string['validationmsg_maturity_help'] = 'The plugin can declare its maturity level. If the maintainer considers the plugin stable, the declared maturity level will read MATURITY_STABLE. All other maturity levels (such as alpha or beta) should be considered unstable and a warning is raised.';
72$string['validationmsg_missingexpectedlangenfile'] = 'English language file name mismatch';
73$string['validationmsg_missingexpectedlangenfile_info'] = 'The given plugin type is missing the expected English language file {$a}.';
74$string['validationmsg_missinglangenfile'] = 'No English language file found';
75$string['validationmsg_missinglangenfolder'] = 'Missing English language folder';
76$string['validationmsg_missingversion'] = 'Plugin does not declare its version';
77$string['validationmsg_missingversionphp'] = 'File version.php not found';
78$string['validationmsg_multiplelangenfiles'] = 'Multiple English language files found';
79$string['validationmsg_onedir'] = 'Invalid structure of the ZIP package.';
80$string['validationmsg_onedir_help'] = 'The ZIP package must contain just one root directory that holds the plugin code. The name of that root directory must match the name of the plugin.';
81$string['validationmsg_pathwritable'] = 'Write access check';
82$string['validationmsg_pluginversion'] = 'Plugin version';
83$string['validationmsg_release'] = 'Plugin release';
84$string['validationmsg_requiresmoodle'] = 'Required Moodle version';
85$string['validationmsg_rootdir'] = 'Name of the plugin to be installed';
86$string['validationmsg_rootdir_help'] = 'The name of the root directory in the ZIP package forms the name of the plugin to be installed. If the name is not correct, you may wish to rename the root directory in the ZIP prior to installing the plugin.';
87$string['validationmsg_rootdirinvalid'] = 'Invalid plugin name';
88$string['validationmsg_rootdirinvalid_help'] = 'The name of the root directory in the ZIP package violates formal syntax requirements. Some ZIP packages, such as those generated by Github, may contain an incorrect root directory name. You need to fix the name of the root directory to match the plugin name.';
89$string['validationmsg_targetexists'] = 'Target location already exists';
90$string['validationmsg_targetexists_help'] = 'The directory that the plugin is to be installed to must not yet exist.';
91$string['validationmsg_unknowntype'] = 'Unknown plugin type';
92$string['validationmsglevel_debug'] = 'Debug';
93$string['validationmsglevel_error'] = 'Error';
94$string['validationmsglevel_info'] = 'OK';
95$string['validationmsglevel_warning'] = 'Warning';
96$string['validationresult0'] = 'Validation failed!';
97$string['validationresult0_help'] = 'A serious problem was detected and so it is not safe to install the plugin. See the validation log messages for details.';
98$string['validationresult1'] = 'Validation passed!';
99$string['validationresult2_help'] = 'No serious problems were detected. You can continue with the plugin installation. See the validation log messages for more details and eventual warnings.';
100$string['validationresult1_help'] = 'The plugin package has been validated and no serious problems were detected.';
101$string['validationresultinfo'] = 'Info';
102$string['validationresultmsg'] = 'Message';
103$string['validationresultstatus'] = 'Status';
Note: See TracBrowser for help on using the repository browser.