source: moodle/trunk/fuentes/enrol/manual/db/upgrade.php @ 1331

Last change on this file since 1331 was 1331, checked in by jrpelegrina, 3 years ago

Updated to moodle 3.0.3

File size: 2.6 KB
Line 
1<?php
2// This file is part of Moodle - http://moodle.org/
3//
4// Moodle is free software: you can redistribute it and/or modify
5// it under the terms of the GNU General Public License as published by
6// the Free Software Foundation, either version 3 of the License, or
7// (at your option) any later version.
8//
9// Moodle is distributed in the hope that it will be useful,
10// but WITHOUT ANY WARRANTY; without even the implied warranty of
11// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
12// GNU General Public License for more details.
13//
14// You should have received a copy of the GNU General Public License
15// along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
16
17/**
18 * This file keeps track of upgrades to the manual enrolment plugin
19 *
20 * @package    enrol_manual
21 * @copyright  2012 Petr Skoda {@link http://skodak.org
22 * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
23 */
24
25defined('MOODLE_INTERNAL') || die();
26
27function xmldb_enrol_manual_upgrade($oldversion) {
28    global $CFG, $DB, $OUTPUT;
29
30    $dbman = $DB->get_manager();
31
32    // Moodle v2.3.0 release upgrade line
33    // Put any upgrade step following this
34
35    if ($oldversion < 2012100702) {
36        // Set default expiry threshold to 1 day.
37        $DB->execute("UPDATE {enrol} SET expirythreshold = 86400 WHERE enrol = 'manual' AND expirythreshold = 0");
38        upgrade_plugin_savepoint(true, 2012100702, 'enrol', 'manual');
39    }
40
41    if ($oldversion < 2012101400) {
42        // Delete obsoleted settings, now using expiry* prefix to make them more consistent.
43        unset_config('notifylast', 'enrol_manual');
44        unset_config('notifyhour', 'enrol_manual');
45        upgrade_plugin_savepoint(true, 2012101400, 'enrol', 'manual');
46    }
47
48
49    // Moodle v2.4.0 release upgrade line
50    // Put any upgrade step following this
51
52
53    // Moodle v2.5.0 release upgrade line.
54    // Put any upgrade step following this.
55
56
57    // Moodle v2.6.0 release upgrade line.
58    // Put any upgrade step following this.
59
60    // Moodle v2.7.0 release upgrade line.
61    // Put any upgrade step following this.
62
63    // Moodle v2.8.0 release upgrade line.
64    // Put any upgrade step following this.
65
66    // Moodle v2.9.0 release upgrade line.
67    // Put any upgrade step following this.
68
69    if ($oldversion < 2015091500) {
70        // We keep today as default enrolment start time on upgrades.
71        set_config('enrolstart', 3, 'enrol_manual');
72        upgrade_plugin_savepoint(true, 2015091500, 'enrol', 'manual');
73    }
74
75    // Moodle v3.0.0 release upgrade line.
76    // Put any upgrade step following this.
77
78    return true;
79}
80
81
Note: See TracBrowser for help on using the repository browser.