source: n4d/trunk/fuentes/debian/n4d.prerm @ 110

Last change on this file since 110 was 110, checked in by hectorgh, 3 years ago

wip

File size: 1.0 KB
Line 
1#!/bin/sh
2# prerm script for llxcfg-adc
3#
4# see: dh_installdeb(1)
5
6set -e
7
8CERTPATH="/etc/lliurex-secrets/n4d/cert/n4d"
9# summary of how this script can be called:
10#        * <prerm> `remove'
11#        * <old-prerm> `upgrade' <new-version>
12#        * <new-prerm> `failed-upgrade' <old-version>
13#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
14#        * <deconfigured's-prerm> `deconfigure' `in-favour'
15#          <package-being-installed> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    remove)
23        # Remove certificates
24        if [ -f $CERTPATH ]; then
25                rm -rf /etc/n4d/cert || true
26        fi
27    ;;
28
29    failed-upgrade)
30        ;;
31        upgrade|deconfigure)
32    ;;
33
34    *)
35        echo "prerm called with unknown argument \`$1'" >&2
36        exit 1
37    ;;
38esac
39
40# dh_installdeb will replace this with shell code automatically
41# generated by other debhelper scripts.
42
43#DEBHELPER#
44
45exit 0
46
Note: See TracBrowser for help on using the repository browser.