source: php5-lliurex-compat/fuentes/debian/prerm @ 1224

Last change on this file since 1224 was 1224, checked in by mabarracus, 3 years ago

fixes

File size: 973 bytes
Line 
1#!/bin/sh
2# prerm script for php5-lliurex-compat
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <prerm> `remove'
10#        * <old-prerm> `upgrade' <new-version>
11#        * <new-prerm> `failed-upgrade' <old-version>
12#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
13#        * <deconfigured's-prerm> `deconfigure' `in-favour'
14#          <package-being-installed> <version> `removing'
15#          <conflicting-package> <version>
16# for details, see https://www.debian.org/doc/debian-policy/ or
17# the debian-policy package
18
19
20case "$1" in
21    remove|upgrade|deconfigure)
22        systemctl stop apache2-lliurex || true
23        systemctl disable apache2-lliurex || true
24    ;;
25
26    failed-upgrade)
27    ;;
28
29    *)
30        echo "prerm called with unknown argument \`$1'" >&2
31        exit 1
32    ;;
33esac
34
35# dh_installdeb will replace this with shell code automatically
36# generated by other debhelper scripts.
37
38#DEBHELPER#
39
40exit 0
Note: See TracBrowser for help on using the repository browser.