Ignore:
Timestamp:
May 2, 2016, 12:09:23 PM (3 years ago)
Author:
jrpelegrina
Message:

Updated to moodle 3.0.3

File:
1 edited

Legend:

Unmodified
Added
Removed
  • moodle/trunk/fuentes/auth/ldap/db/upgrade.php

    r136 r1331  
    4949    // Put any upgrade step following this.
    5050
     51    if ($oldversion < 2014111001) {
     52        global $DB;
     53        // From now on the default LDAP objectClass setting for AD has been changed, from 'user' to '(samaccounttype=805306368)'.
     54        if (is_enabled_auth('ldap')
     55                && ($DB->get_field('config_plugins', 'value', array('name' => 'user_type', 'plugin' => 'auth/ldap')) === 'ad')
     56                && ($DB->get_field('config_plugins', 'value', array('name' => 'objectclass', 'plugin' => 'auth/ldap')) === '')) {
     57            // Save the backwards-compatible default setting.
     58            set_config('objectclass', 'user', 'auth/ldap');
     59        }
     60
     61        upgrade_plugin_savepoint(true, 2014111001, 'auth', 'ldap');
     62    }
     63
     64    // Moodle v2.9.0 release upgrade line.
     65    // Put any upgrade step following this.
     66
     67    // Moodle v3.0.0 release upgrade line.
     68    // Put any upgrade step following this.
     69
    5170    return true;
    5271}
Note: See TracChangeset for help on using the changeset viewer.