Changeset 1483 for php5-lliurex-compat


Ignore:
Timestamp:
May 12, 2016, 9:31:53 AM (4 years ago)
Author:
mabarracus
Message:

Fix checking old installation

Location:
php5-lliurex-compat/fuentes/debian
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • php5-lliurex-compat/fuentes/debian/changelog

    r1472 r1483  
     1php5-lliurex-compat (0.5-2) xenial; urgency=medium
     2
     3  * FIX old installation detection
     4
     5 -- M.Angel Juan <m.angel.juan@gmail.com>  Thu, 12 May 2016 09:31:09 +0200
     6
    17php5-lliurex-compat (0.5-1) xenial; urgency=medium
    28
  • php5-lliurex-compat/fuentes/debian/postinst

    r1472 r1483  
    1919NOW=$(date +'%Y%m%d%h%m')
    2020setup_apache(){
     21    INST="/etc/apache2-lliurex"
     22    FILES="ports.conf apache2.conf envvars"
     23    IS_DONE=0
     24    for file in $FILES; do
     25        if [ -f ${INST}/${file} ]; then
     26            IS_DONE=1
     27        fi
     28    done
     29    if [ ${IS_DONE} -eq 1 ]; then
     30            echo "Apache2 multi-instance seems already configured, skipping multi-instance configuration"
     31            return
     32    fi
     33   
    2134    echo "Setting up apache multi-instance"
    2235    if [ ! -f /usr/share/doc/apache2/examples/setup-instance ]; then
     
    8295            echo "Apache2 multi-instance seems already configured, skipping multi-instance configuration"
    8396        else
    84             setup_apache
    85         fi
     97        setup_apache
    8698        change_ports
    8799        fix_mods
Note: See TracChangeset for help on using the changeset viewer.