Ignore:
Timestamp:
Apr 20, 2017, 2:50:46 PM (3 years ago)
Author:
Juanma
Message:

Bugfix with removing debs and version mismatching between installed and available

File:
1 edited

Legend:

Unmodified
Added
Removed
  • lliurex-store/trunk/fuentes/python3-lliurex-store.install/usr/share/lliurexstore/storeManager.py

    r4363 r4370  
    485485                        #Check if package is installed if we want to remove it or vice versa
    486486                        for appInfo in applistInfo:
    487                                 if (action=='install' and appInfo['state']=='installed') or (action=='remove' and appInfo['state']=='available'):
     487#                               if (action=='install' and appInfo['state']=='installed') or (action=='remove' and appInfo['state']=='available'):
     488                                if (action=='remove' and appInfo['state']=='available'):
    488489                                        if action=='remove':
    489490#                                               self.result[action]['status']={appInfo['package']:3}
     
    491492                                        else:
    492493#                                               self.result[action]['status']={appInfo['package']:4}
    493                                                 self.result[action]['status']={'status':4}
     494#                                               self.result[action]['status']={'status':4}
     495                                                pass
    494496                                        return_msg=False
    495497                                        typeDict={}
Note: See TracChangeset for help on using the changeset viewer.