Changeset 4776


Ignore:
Timestamp:
May 16, 2017, 12:47:50 PM (2 years ago)
Author:
Juanma
Message:

Updated to 2.3.2-1

Location:
qstopmotion/trunk/fuentes
Files:
1 added
2 edited

Legend:

Unmodified
Added
Removed
  • qstopmotion/trunk/fuentes/CMakeLists.txt

    r4773 r4776  
    365365)
    366366
    367 SET(
    368     DEB_FILES
    369     deb/qstopmotion.xpm       # DEB Icon is installed in a separate step
    370     deb/changelog             # DEB changelog file
    371     deb/changelog.gz          # DEB changelog file compressed
    372     deb/copyright             # DEB copyright file
    373     deb/qstopmotion.menu      # DEB .menu is installed in a separate step for Debian systems
    374     deb/postinst              # DEB post installation script file, call update-menus
    375 )
    376 
    377 SET(
    378     RPM_FILES
    379     rpm/qstopmotion.png       # RPM Icon is installed in a separate step
    380 )
    381 
    382367###############################################################################
    383368# gPhoto2 support
     
    597582    file(COPY ${GENERAL_FILES} DESTINATION "share/qstopmotion/")
    598583    file(COPY ${UNIX_FILES} DESTINATION "share/qstopmotion/")
    599     file(COPY ${DEB_FILES} DESTINATION "share/qstopmotion/deb/")
    600     file(COPY ${RPM_FILES} DESTINATION "share/qstopmotion/rpm/")
    601584ENDIF(UNIX AND NOT APPLE)
    602585
     
    699682    )
    700683ENDIF(UNIX AND NOT APPLE)
    701 
    702 # installation on DEB systems
    703 IF(CPACK_BINARY_DEB)
    704     message("Special task for deb package!")
    705    
    706     # installation of the icon file
    707     install(
    708         FILES "deb/qstopmotion.xpm"
    709         DESTINATION ${QSTOPMOTION_PIXMAP_INSTALL_DIR}
    710     )
    711 
    712     # installation of the .menufile file
    713     install(
    714         FILES "deb/qstopmotion.menu"
    715         DESTINATION ${QSTOPMOTION_MENUFILE_INSTALL_DIR}
    716     )
    717 
    718     # installation of the changelog file
    719     install(
    720         FILES "deb/changelog.gz"
    721         DESTINATION ${QSTOPMOTION_MANUAL_INSTALL_DIR}
    722     )
    723 
    724     # installation of the copyright file
    725     install(
    726         FILES "deb/copyright"
    727         DESTINATION ${QSTOPMOTION_MANUAL_INSTALL_DIR}
    728     )
    729 ENDIF(CPACK_BINARY_DEB)
    730 
    731 # installation on RPM systems
    732 IF(CPACK_BINARY_RPM)
    733     message("Special task for rpm package!")
    734    
    735     # installation of the general-purpose files
    736     install(
    737         FILES ${GENERAL_FILES}
    738         DESTINATION ${QSTOPMOTION_GENERALS_INSTALL_DIR}
    739     )
    740 
    741     # installation of the icon file
    742     install(
    743         FILES "rpm/qstopmotion.png"
    744         DESTINATION ${QSTOPMOTION_PIXMAP_INSTALL_DIR}
    745     )
    746 ENDIF(CPACK_BINARY_RPM)
    747684
    748685# installation on Windows systems
     
    1059996# SET(CPACK_NSIS_MUI_FINISHPAGE_RUN "qstopmotion.exe"
    1060997
    1061 ###############################################################################
    1062 # DEB package - Linux only (Debian, OpenSuse, Ubuntu, ...)
    1063 ###############################################################################
    1064 
    1065 IF ("${LSB_DISTRIB}" MATCHES "Ubuntu|Debian")
    1066     # We need to alter the architecture names as per distro rules
    1067     IF ("${CPACK_PACKAGE_ARCHITECTURE}" MATCHES "i[3-6]86")
    1068         SET(
    1069             CPACK_PACKAGE_ARCHITECTURE
    1070             "i386"
    1071         )
    1072     ENDIF ("${CPACK_PACKAGE_ARCHITECTURE}" MATCHES "i[3-6]86")
    1073     IF ("${CPACK_PACKAGE_ARCHITECTURE}" MATCHES "x86_64")
    1074         SET(
    1075             CPACK_PACKAGE_ARCHITECTURE
    1076             "amd64"
    1077         )
    1078     ENDIF ("${CPACK_PACKAGE_ARCHITECTURE}" MATCHES "x86_64")
    1079     SET(
    1080         CPACK_SYSTEM_NAME
    1081         "${LSB_DISTRIB}-${CPACK_PACKAGE_ARCHITECTURE}"
    1082     )
    1083 
    1084     # Set the dependencies based on the distro version
    1085     # thus only one package is build you must list here *any* depending libraries,
    1086     # even if they are only used in one module
    1087     IF ("${LSB_DISTRIB}" MATCHES "Ubuntu14.04")
    1088         SET(
    1089             CPACK_DEBIAN_PACKAGE_DEPENDS
    1090             "libc6 (>=2.11), libavbin0 (>=7-1), libqt5core5 (>=5.2.1) | libqt5core5a (>=5.2.1), libqt5gui5 (>=5.2.1), libqt5widgets5 (>=5.2.1), libqt5xml5 (>=5.2.1), libv4l-0 (>=1.0.0), libgphoto2-6 (>=2.5.3), qt5-image-formats-plugins (>=5.2.1)"
    1091         )
    1092     ENDIF ("${LSB_DISTRIB}" MATCHES "Ubuntu14.04")
    1093     IF ("${LSB_DISTRIB}" MATCHES "Ubuntu16.04")
    1094         SET(
    1095             CPACK_DEBIAN_PACKAGE_DEPENDS
    1096             "libc6 (>=2.11), ffmpeg (>=2.8.6), libqt5core5 (>=5.3.2) | libqt5core5a (>=5.3.2), libqt5gui5 (>=5.3.2), libqt5widgets5 (>=5.3.2), libqt5xml5 (>=5.3.2), libv4l-0 (>=1.0.0), libgphoto2-6 (>=2.5.3), qt5-image-formats-plugins (>=5.3.2)"
    1097         )
    1098     ENDIF ("${LSB_DISTRIB}" MATCHES "Ubuntu16.04")
    1099     IF ("${LSB_DISTRIB}" MATCHES "Debian7.*")
    1100         SET(
    1101             CPACK_DEBIAN_PACKAGE_DEPENDS
    1102             "libc6 (>=2.11), ffmpeg (>=0.8.9), libqtcore4 (>=4.8.2), libqtgui4 (>=4.8.2), libqt4-xml (>=4.8.2), libv4l-0 (>=0.8.8), libgphoto2-2 (>=2.4.14), libgphoto2-port0 (>=2.4.14)"
    1103         )
    1104     ENDIF ("${LSB_DISTRIB}" MATCHES "Debian7.*")
    1105     IF ("${LSB_DISTRIB}" MATCHES "Debian8.*")
    1106         SET(
    1107             CPACK_DEBIAN_PACKAGE_DEPENDS
    1108             "libc6 (>=2.11), libav-tools (>=6:11.3), libqt5core5 (>=5.3.2) | libqt5core5a (>=5.3.2), libqt5gui5 (>=5.3.2), libqt5widgets5 (>=5.3.2), libqt5xml5 (>=5.3.2), libv4l-0 (>=1.0.0), libgphoto2-6 (>=2.5.3), qt5-image-formats-plugins (>=5.3.2)"
    1109         )
    1110     ENDIF ("${LSB_DISTRIB}" MATCHES "Debian8.*")
    1111     IF (NOT CPACK_DEBIAN_PACKAGE_DEPENDS)
    1112         MESSAGE ("WARNING: ${LSB_DISTRIB} not supported yet.\nPlease set deps in CMakeLists.txt before packaging.")
    1113     ENDIF (NOT CPACK_DEBIAN_PACKAGE_DEPENDS)
    1114 ENDIF ("${LSB_DISTRIB}" MATCHES "Ubuntu|Debian")
    1115 MESSAGE("CPACK_DEBIAN_PACKAGE_DEPENDS: ${CPACK_DEBIAN_PACKAGE_DEPENDS}")
    1116 
    1117 # Mandatory
    1118 # CPACK_DEBIAN_PACKAGE_NAME = CPACK_PACKAGE_NAME
    1119 MESSAGE("CPACK_DEBIAN_PACKAGE_NAME: ${CPACK_DEBIAN_PACKAGE_NAME}")
    1120 # CPACK_DEBIAN_PACKAGE_VERSION = CPACK_PACKAGE_VERSION
    1121 MESSAGE("CPACK_DEBIAN_PACKAGE_VERSION: ${CPACK_DEBIAN_PACKAGE_VERSION}")
    1122 # CPACK_DEBIAN_PACKAGE_ARCHITECTURE = dpkg output       # dpkg --print-architecture ???
    1123 MESSAGE("CPACK_DEBIAN_PACKAGE_ARCHITECTURE: ${CPACK_DEBIAN_PACKAGE_ARCHITECTURE}")
    1124 # CPACK_DEBIAN_PACKAGE_MAINTAINER = CPACK_PACKAGE_CONTACT
    1125 MESSAGE("CPACK_DEBIAN_PACKAGE_MAINTAINER: ${CPACK_DEBIAN_PACKAGE_MAINTAINER}")
    1126 SET(
    1127     CPACK_DEBIAN_PACKAGE_DESCRIPTION
    1128     "create stop motion animations\n qStopMotion can be used to create stop motion animations."
    1129 )
    1130 MESSAGE("CPACK_DEBIAN_PACKAGE_DESCRIPTION: ${CPACK_DEBIAN_PACKAGE_DESCRIPTION}")
    1131 SET(
    1132     CPACK_DEBIAN_PACKAGE_SECTION
    1133     "graphics"
    1134 )
    1135 MESSAGE("CPACK_DEBIAN_PACKAGE_SECTION: ${CPACK_DEBIAN_PACKAGE_SECTION}")
    1136 SET(
    1137     CPACK_DEBIAN_PACKAGE_PRIORITY
    1138     "optional"
    1139 )
    1140 MESSAGE("CPACK_DEBIAN_PACKAGE_PRIORITY: ${CPACK_DEBIAN_PACKAGE_PRIORITY}")
    1141 
    1142 # Options
    1143 
    1144 SET(CPACK_DEBIAN_PACKAGE_HOMEPAGE ${QSTOPMOTION_HOMEPAGE})
    1145 # CPACK_DEBIAN_PACKAGE_SHLIBDEPS
    1146 # SET(CPACK_DEBIAN_PACKAGE_DEBUG "ON")
    1147 # CPACK_DEBIAN_PACKAGE_DEBUG
    1148 # CPACK_DEBIAN_PACKAGE_ENHANCES
    1149 # CPACK_DEBIAN_PACKAGE_BREAKS
    1150 # CPACK_DEBIAN_PACKAGE_CONFLICTS
    1151 # CPACK_DEBIAN_PACKAGE_PROVIDES
    1152 # CPACK_DEBIAN_PACKAGE_REPLACES
    1153 SET(
    1154     CPACK_DEBIAN_PACKAGE_CONTROL_EXTRA
    1155     "${CMAKE_SOURCE_DIR}/deb/postinst"
    1156 )
    1157 
    1158 ###############################################################################
    1159 # RPM package - Linux only (Fedora, Red Hat, CentOS, Mandriva, ...)
    1160 ###############################################################################
    1161 
    1162 # Mandatory
    1163 SET(
    1164     CPACK_RPM_PACKAGE_SUMMARY
    1165     ${CPACK_PACKAGE_DESCRIPTION_SUMMARY}
    1166 )
    1167 MESSAGE("CPACK_RPM_PACKAGE_SUMMARY: ${CPACK_RPM_PACKAGE_SUMMARY}")
    1168 # CPACK_RPM_PACKAGE_NAME = CPACK_PACKAGE_NAME
    1169 MESSAGE("CPACK_RPM_PACKAGE_NAME: ${CPACK_RPM_PACKAGE_NAME}")
    1170 # CPACK_RPM_PACKAGE_VERSION = CPACK_PACKAGE_VERSION
    1171 MESSAGE("CPACK_RPM_PACKAGE_VERSION: ${CPACK_RPM_PACKAGE_VERSION}")
    1172 # SET(CPACK_RPM_PACKAGE_RELEASE "1")
    1173 MESSAGE("CPACK_RPM_PACKAGE_RELEASE: ${CPACK_RPM_PACKAGE_RELEASE}")
    1174 SET(
    1175     CPACK_RPM_PACKAGE_LICENSE
    1176     "GPLv2"
    1177 )
    1178 MESSAGE("CPACK_RPM_PACKAGE_LICENSE: ${CPACK_RPM_PACKAGE_LICENSE}")
    1179 SET(
    1180     CPACK_RPM_PACKAGE_GROUP
    1181     "Applications/Multimedia"
    1182 )
    1183 MESSAGE("CPACK_RPM_PACKAGE_GROUP: ${CPACK_RPM_PACKAGE_GROUP}")
    1184 # CPACK_RPM_PACKAGE_VENDOR = CPACK_PACKAGE_VENDOR
    1185 MESSAGE("CPACK_RPM_PACKAGE_VENDOR: ${CPACK_RPM_PACKAGE_VENDOR}")
    1186 # CPACK_RPM_PACKAGE_MAINTAINER = CPACK_PACKAGE_CONTACT
    1187 MESSAGE("CPACK_RPM_PACKAGE_MAINTAINER: ${CPACK_RPM_PACKAGE_MAINTAINER}")
    1188 
    1189 # Options
    1190 # SET(CPACK_RPM_PACKAGE_ARCHITECTURE "noarch")
    1191 SET(
    1192     CPACK_RPM_PACKAGE_URL
    1193     ${QSTOPMOTION_HOMEPAGE}
    1194 )
    1195 # CPACK_RPM_PACKAGE_DESCRIPTION = CPACK_PACKAGE_DESCRIPTION_FILE
    1196 # CPACK_RPM_COMPRESSION_TYPE
    1197 # requireses must be in a aphabetic order
    1198 # Qt5: qt5-qtbase - Core, Concurrent, DBus, Network, Sql, Test, Xml
    1199 # Qt5: qt5-qtbase-gui - Gui, OpenGL, PrintSupport, Widgets, XcbQpa
    1200 # Qt5: qt5-qtimageformats - Qt5 image format plugins
    1201 # Qt5: qt5-qtmultimedia - Multimedia, MultimediaQuick, MultimediaWidgets
    1202 SET(
    1203     CPACK_RPM_PACKAGE_REQUIRES
    1204     "glibc >= 2.12, libgphoto2 >= 2.4.7, libv4l >= 0.6.3, qt5-qtbase >= 5.2.0, qt5-qtbase-gui >= 5.2.0, qt5-qtimageformats >= 5.2.0"
    1205 )
    1206 MESSAGE("CPACK_RPM_PACKAGE_REQUIRES: ${CPACK_RPM_PACKAGE_REQUIRES}")
    1207 # CPACK_RPM_PACKAGE_SUGGESTS
    1208 # CPACK_RPM_PACKAGE_PROVIDES
    1209 
    1210 # SET(CPACK_RPM_SPEC_INSTALL_POST "desktop-file-validate /usr/share/applications/qstopmotion.desktop")
    1211 
    1212 # SET(CPACK_RPM_PRE_INSTALL_SCRIPT_FILE "pre_install.sh")
    1213 # SET(CPACK_RPM_POST_INSTALL_SCRIPT_FILE "post_install.sh")
    1214 # SET(CPACK_RPM_PRE_UNINSTALL_SCRIPT_FILE "pre_install.sh")
    1215 # SET(CPACK_RPM_POST_UNINSTALL_SCRIPT_FILE "post_install.sh")
    1216 
    1217 # Prevent conflicts with the filesystem package
    1218 SET(
    1219     CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION
    1220     "/usr/bin"
    1221     "/usr/share/applications"
    1222     "/usr/share/icons"
    1223     "/usr/share/pixmaps"
    1224     "/usr/share/man"
    1225     "/usr/share/man/man1"
    1226 )
    1227998
    1228999###############################################################################
  • qstopmotion/trunk/fuentes/debian/patches/series

    r4774 r4776  
    11cmakelists.patch
     2makeBuild
Note: See TracChangeset for help on using the changeset viewer.