Changeset 6864


Ignore:
Timestamp:
Feb 19, 2018, 12:44:26 PM (18 months ago)
Author:
hectorgh
Message:

trying to support new firefox ESR

Location:
lliurex-dgti-defaults-configs/trunk/fuentes/debian
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • lliurex-dgti-defaults-configs/trunk/fuentes/debian/postinst

    r6536 r6864  
    3939                ln -s /opt/firefox-esr/firefoxESR /usr/bin/firefox
    4040        fi
     41
    4142        alternative=$(readlink -f /etc/alternatives/java)
    4243        oracle_value='/usr/lib/jvm/java-8-oracle/jre/bin/java'
  • lliurex-dgti-defaults-configs/trunk/fuentes/debian/preinst

    r6175 r6864  
    1616
    1717case "$1" in
    18     install)
    19        
    20     ;;
    21     upgrade)
     18    install | upgrade)
     19        CURRENT_FIREFOX=$(readlink -f /usr/bin/firefox)
     20        if [ "$CURRENT_FIREFOX" = "/opt/firefox-esr/firefox" ]; then
     21                rm -rf /usr/bin/firefox || true
     22                ln -s /opt/firefox-esr/firefoxESR-bin /usr/bin/firefox
     23        fi     
    2224    ;;
    2325    abort-upgrade)
Note: See TracChangeset for help on using the changeset viewer.