Changeset 6910


Ignore:
Timestamp:
Feb 23, 2018, 8:52:02 AM (18 months ago)
Author:
Juanma
Message:

Release version

Location:
lliurex-on-fire/trunk/fuentes
Files:
1 added
2 edited

Legend:

Unmodified
Added
Removed
  • lliurex-on-fire/trunk/fuentes/generate_addons.sh

    r6891 r6910  
    44
    55ADDON=lliurex-on-fire
     6NODE_MIN_VERSION=6
    67BASE_DIR=${PWD}
    78#If the .pem file changes CHROMIUM_ID will change and must be updated "manually"
     
    8081#rm -fr $CHROMIUM_DIR/*crx 2>/dev/null
    8182#rm -fr $FIREFOX_DIR/*xpi 2>/dev/null
    82 [ -z $(which npm) ] && echo "Install nodejs (>=6.0) to proceed" && exit 1
     83NODE_VERSION=$(nodejs -v)
     84if [ ${NODE_VERSION:1:1} -lt $NODE_MIN_VERSION ]
     85then
     86        echo "At least version $NODE_MIN_VERSION.x is needed for nodejs. Your current version is $NODE_VERSION"
     87        exit 1
     88fi
     89[ -z $(which npm) ] && echo "Install nodejs (>=6.0) to proceed" && exit 2
    8390[ ! -z $(which chromium-browser) ] && generate_chromium_addon
    8491rm -fr $BUILD_DIR 2>/dev/null
Note: See TracChangeset for help on using the changeset viewer.