Changeset 8785


Ignore:
Timestamp:
Dec 10, 2019, 3:03:26 PM (3 months ago)
Author:
hectorgh
Message:

forcing n4d restart if installed version is less than 0.3.10

Location:
client-mount/trunk/fuentes/debian
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • client-mount/trunk/fuentes/debian/changelog

    r8784 r8785  
    1 client-mount (0.3.9) xenial; urgency=high
     1client-mount (0.3.10) xenial; urgency=high
    22
    3   * forcing vers=1.0
     3  * forcing vers=1.0 as kernel 4.15 needs to be told which cifs version to use
    44
    55 -- Hector Garcia Huerta <hectorgh@gmail.com>  Tue, 10 Dec 2019 14:50:03 +0100
  • client-mount/trunk/fuentes/debian/postinst

    r6599 r8785  
    3737                n4d-modules enable-plugin /etc/n4d/conf.d/ClientPamMount || true
    3838
     39
     40                if dpkg --compare-versions "$2" lt 0.3.10; then
     41
     42                        if [ -e /tmp/.n4d_pid ]; then
     43                                rm -rf /tmp/.n4d_pid || true
     44                        fi
     45                        deb-systemd-invoke restart n4d || true
     46                fi
     47
    3948    ;;
    4049
Note: See TracChangeset for help on using the changeset viewer.